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 SECTION 1:  General Description 

1.1. Background 

The QWIKLINK™ LIS Interface is a Windows application, stand alone module that is 

activated upon start-up and continues to run in the background of the SQA-V/V-

Sperm Gold system. The program retrieves data from the V-sperm data base and 

sends it to an external host via an RS232 connection.   

1.2. Concept 

The program, installed in the V-Sperm Gold folder, accesses the V-Sperm Gold 

database. The program searches for the text file: LMSPAR.TXT that is located in the 

application folder. This text file contains each and every parameter that can be 

retrieved from the data base.  

The interval time for running the LIS Interface is set by the user.  The default is five 

minutes. An icon will indicate when the program is running and when it is idle. The 

program will generate an error log file (error.log) when appropriate.   

1.3. Document Overview 

This document provides instructions for loading the LIS software, setting up the 

system defaults and installing the RS232 drivers.  

 SECTION 2: Installation 
 
 
 

RS232 
connection 

Phase 1: Communication cable: 
Connect one end of the RS232 communication cable to the V-

Sperm computer and the other end of the cable to the Host 

computer as shown. 

 

USB to 
RS232 

Converter 
Cable 

If there is no free RS232 port, use the USB to RS232 Converter 

Cable: 

▪ Connect the other end of the USB to RS232 converter cable 

to the RS232 data cable that is connected to the Host 

computer, as shown below. (See Phase 1.1 for the USB to 

RS232 Converter installation instructions). 

 

 

RS232 computer connection 

USB computer connection 

USB to RS232 Converter Cable 

RS232 Data Cable 
(Connects to the Host Computer) 
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Phase 1.1: USB to RS232 Converter Cable Installation 

1. Close all open programs. 

2. Insert the USB to RS232  FTDI  Drivers CD into the PC 

CD-ROM Insert the USB Driver CD into the PC 

CD-ROM. 

3. From the PC click: START > RUN and type in: 

X:\Win200-XP-Vista\CDM 2.04.06.exe (X = letter 

of PC CD-ROM drive)  

4. Wait a few seconds until the installation process 

is completed (the DOS window displayed below will 
disappear). 

5. Plug-in the USB cable of the USB to RS232 device into 
a USB port on the PC. 

Verifying Proper Installation 

 

6. Click on START > RUN 

7. Type:  devmgmt.msc and click ENTER in order to open 
the Device Manager. 

8. Verify that the driver is installed (check to see the driver 
in the red boxed area displayed above). 

 

Phase 2: Software Installation: 

1. Close all programs that are open and Re-boot 

the computer. 

2. Insert the QwikLink LIS Interface CD into the 

PC CD-ROM. Installation will begin automatically.  

If installation fails to start automatically, Press 

Start->Run x:\Setup.exe (X is the letter of the 

PC CD-ROM drive). 

3. The screen will display: Initializing Wise 
Installation Wizard 

4. When the welcome screen is displayed, click 

NEXT to proceed. 

5. Click NEXT to begin copying files. 
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A gray icon 
indicates the system 
is idling (not 
transferring data).   

 
 

A green icon 
indicates the system 
is running and 
transferring data to 
the host computer. 

 
 
A RED icon 
indicates that an 
error occurred while 
transferring data. 
The system 
continues to 
transfer data but 
some data might be 
missed. For more 
details go to 

View->Log Files 
-> Information    

 
 
 

 
 
 

 
The ‘General’ 
settings screen 
opens after 
installation in order 
to provide an option 
to change the 
default settings. 
 
 
 
 
 

 
 

 
 
 
 

 
 
 
 
 
 
 

Phase 3: Installation Complete 

• Click OK to re-start the computer to complete 

the QWIKLINK™ LIS software installation. 

• After re-start, the QWIKLINK™LIS Interface 

Icon will appear indicating the software is 

running. 

• See PHASE 5.1 below for settings.   

Phase 4.1: General Settings 

1. Right Click on the LIS Interface Icon to 

activate the drop down menu and click: OPEN 

2. Select: Options->General Settings  

 

3. Select/Enter:  

• COMMUNICATION PORT: DO NOT 
SELECT THE COM PORT THAT WAS 
DEFINED FOR V-SPERM. 

• PROCESS INTERVAL TIME: Enter a 

number designating how often data 

should be transferred. The default is 

every 5 minutes. 

• Enable advanced LOG FILE: 
Enable/Disable the 'advanced' log file, 

which tracks transmitted data. The 

default is ‘unselected’. 

• SEND FACILITY HEADER:  

Enable/ Disable ‘facility data transmit’. 

• REMEMBER LAST FRAME NUMBER: 
Normally frame numbers restart from 0 in 

every session.  It is optional to start each 

session with the last frame number used 

in the last session.  

• SEND TEST TYPE (RTY) PARAMETER: 
Enable/ Disable sending ”Test Type” 
parameter(RTY). When changing  to 

protocol 2 (Kaiser), the default option will 

be not to send this parameter. 

• DATA TRANSFER PROTOCOL: Select  

which protocol the data will be 

transferred; Default (Protocol 1) or Kaiser 

(Protocol 2). The manufacturer’s default is 

Protocol 1. 

• WHO STANDARD : Select the WHO 

Standard for semen testing which 

matches the parameters transmitted.  

The default standard is WHO 5th.  

• DATABASE LOCATION: Enable using the 

data base "virtual store" location in case 

the computer UAC (User Account Control) 

settings is enabled. 
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The screen 
RECORDS 
SETTINGS will close 
after pressing any of 
the resend buttons. 
Data will then be 
transferred 
automatically.  

 
 

 
 
 
 

 
 
 

 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 

 
 
 
 
 

Phase 4.2: Resend Data 

1. Select: Options-> Resend Data 

2. Select/Enter:  

• RESEND TESTS: Press the "Resend 

Tests" button to resend all of the regular 

tests (not control tests). 

• RESEND CONTROLS TESTS: Press the 

"Resend Controls Tests" button to resend 

all of the controls tests (Without regular 

tests) 

• RESEND ALL RECORDS: Press "Resend 

All Records" to resend all records. 

• RESEND LAST X OF RECORDS: Enter 

the number of the last regular and 

controls records to retransmit.  Then 

press the "Resend" button. 

 

 

Phase 5.1: Input Data Parameters 

1. Right Click on the LIS Interface Icon to 

activate the drop down menu and click: OPEN 

2. Select: View->Input Data Parameters  

3. Select/Enter:  

• INPUT DATA PARAMETERS TABLE : 
Select/ deselect which parameter to 

transmit by pressing on the box to the left 

of the parameter row. 
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Phase 5.3: Information Log File 

1. Select: View->Log Files->Information  

• INFORMATION LOG FILE : Displays  

information about user usage 

 

Phase 5.4: Transferred Data Log File 

1. Select: View->Log Files->Transferred 

data  

• ENABLE ADVANCED LOG FILE : If 

checked in the "General Settings", the 

transmitted data will be shown.  

Phase 5.5: Show/Hide Status Bar 

1. Select: View->Show/Hide Status Bar 

• TRANSMITTED LINE NUMBER: Shows 

the current and total number of lines that 

will be transmitted.  

• SOFTWARE INTERNAL STAGES: 
Displays information (for technical 

support) about the internal stages of the 

timer and the I/O. 
 

Phase 6: About 

1. Select: About 

• MES INFORMATION: Display the version 

of the current V-Sperm and Qwiklink LIS. 

• OPERATION SYSTEM INFORMATION: 
Displays details about the current PC 

(type, CSD version and UAC status). 

• SOURCE FILES AND FOLDERS: Display 

the location of various files and folders 

related to V-Sperm and Qwiklink LIS 

(press the "V-Sperm Folder" or "Database 

Folder" to open them). 
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SECTION 3: QwikLink LIS Interface 

Phase 1:  QwikLink LIS Concept Review 

 The QwikLink LIS is installed in the V-Sperm Gold folder and accesses the V-Sperm Gold 

database.  

 The program searches for the text file: LMSPAR.TXT that is located in the application folder. 

This text file contains each and every parameter that can be retrieved from the data base.  

 The interval time for running the LIS Interface is set by the user. The default is five minutes.  

 An icon will indicate when the program is running and when it is idle.  

 The program will generate an error log file (QwikLinkLIS_Information.log) when appropriate. 

Phase 2:  Dependencies 

 MES V-Sperm Gold software 3.49/3.48/3.60 is required 

Phase 3:  Development Environment 
 Visual Basic 

 

Phase 4:  Error Messages 
ERROR 1 

• No response to the enquiry sent to the HOST indicating a communication error 

• The program will be closed  

ERROR 2 

• The checksum calculated by the HOST does not match the SQA-V five consecutive 

times indicating a data transfer problem. 

• The program will be closed  

ERROR 3 

• The HOST does not acknowledge that the transfer is complete indicating a 

communication error 

• The program will set the status to IDLE 

ERROR 4 

• Wrong character at the beginning acknowledged from the HOST indicating a problem 

with data transfer  

• The program will set the status to IDLE 

ERROR 5 

• Wrong character at the end acknowledged from the HOST indicating a  problem with 

data transfer  

• The program will set the status to IDLE 

ERROR 99 

• Internal function problem  

• Write 99 in the log and document the name of the function 

• The program will be closed 
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Phase 5: Input Parameter File 

File name: LMSPAR3/4/5.TXT  (Appendix 1.0) 

This parameter file is a CSV format text file. Each parameter contained in this file is further 

described/defined by the following five fields. 

• TRANSFER OPTIONS to the HOST - mark each parameter with the following indicator: 

▪ [1] Indicates that the parameter is to be transferred.  

▪ [0] Indicates that the parameter will not be transferred.  

• FIELD CODE 

• FIELD DATABASE SOURCE 

• FIELD FORMAT 

• FIELD DESCRIPTION  

• MESSAGE TYPE INDICATOR – each parameter is marked with the following indicator: 

▪ [H] Indicates a Facility Data parameter.  

▪ [P] Indicates a Patient Data parameter. 

▪ [O] Indicates a Test Data parameter. 

• GROUP TYPE INDICATOR – each parameter is marked with the following indicator: 

▪ [0] Header Parameters 

▪ [1] Archive Parameters 

▪ [2] Controls Parameters 

 

Phase 6: User Interface 
Settings 

• Serial Port* 

• Process Interval 

*The serial port definitions are set to: Baud Rate = 19200; Data Bits =8; Parity = None; Stop 

Bits = 1; Flow Control = None 

 

Start  (Initiate data-transfer process)  

Exit 

Phase 7: Tray Menu 

Open 

Exit 
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Appendix 1.0 – Field List 
 
 
 

 

Transfer  Flag Field Code 
Field Name in 

MES Data Base 
Format Description 

Msg 
Type 

Rec. 
Type 

WHO 
Type 

Facility Data 

AUTOMATIC  MESSQALISV2.0  Header H 0 3/4/5/6 

AUTOMATIC FIC Fields count 0 # Fields in 1 record transferred to LIS H 0 3/4/5/6 

1 or 0 TFN1 TF_Name String Testing Facility name H 0 3/4/5/6 

1 or 0 TFA Address String Testing Facility address H 0 3/4/5/6 

1 or 0 TFC City String Testing Facility City H 0 3/4/5/6 

1 or 0 TFS State String Testing Facility State H 0 3/4/5/6 

1 or 0 TFZ ZIP String Testing Facility ZIP H 0 3/4/5/6 

1 or 0 TFP Phone String Testing Facility Phone H 0 3/4/5/6 

1 or 0 TFF Fax String Testing Facility Fax H 0 3/4/5/6 

Patient Data 

AUTOMATIC PID PatientID String Number identifying the patient P 1 3/4/5/6 

AUTOMATIC RTY Record Type 0 Record Type: 0 –Test 1 – Control P 1 3/4/5/6 

AUTOMATIC FIC Fields count 0 # Fields in 1 record transferred to LIS P 1 3/4/5/6 

1 or 0 PFN FirstName String First name of patient P 1 3/4/5/6 

1 or 0 PLN LastName String Last name of patient P 1 3/4/5/6 

1 or 0 PBD BirthDate String Birth date of patient P 1 3/4/5/6 

Test/Sample Identifying Data 

AUTOMATIC SN# Serial_Number String SQA-V system serial number O 1 3/4/5/6 

AUTOMATIC SID SampleID String Semen sample identification number O 1 3/4/5/6 

AUTOMATIC FIC Fields count 0 # Fields in 1 record transferred to LIS O 1 3/4/5/6 

1 or 0 ATM TestTime HH:MM Time the test was run O 1 3/4/5/6 

1 or 0 ADT TestDate MM/DD/YY Date the test was run O 1 3/4/5/6 

1 or 0 TOP OrderingPhysician String Name of the MD ordering the test O 1 3/4/5/6 

1 or 0 TAS Authoring String Lab person authorizing test results O 1 3/4/5/6 

1 or 0 TPB PersonPerformTest String Lab person performing the test O 1 3/4/5/6 

1 or 0 ABS Abstinence 0 Abstinence (# of days) O 1 3/4/5/6 

1 or 0 VOL Volume 0.0 Volume of the semen sample O 1 3/4/5/6 

1 or 0 COLLDATE Collected_Date MM/DD/YY Date Sample Collected O 1 3/4/5/6 

1 or 0 COLLTIME Collected_Date HH:MM Time Sample Collected O 1 3/4/5/6 

1 or 0 RECEDATE Received_Date MM/DD/YY Date Sample Received O 1 3/4/5/6 

1 or 0 RECETIME Received_Date HH:MM Time Sample Received O 1 3/4/5/6 

1 or 0 SAMTY SampleIndex 0 Normal, Washed, Frozen, Post-Vasectomy O 1 3/4/5/6 

1 or 0 COMMEN Comments_m String Comments from the lab  O 1 3/4/5/6 

1 or 0 MORPHINDEX MorphologyCriteriaIndex        0 Morphology Type  O 1 3/4 

 
1 The Transfer-Flag of the highlighted parameters is set to 1 by default. 
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Transfer  Flag Field Code 
Field Name in 
MES Data Base 

Format Description 
Msg 
Type 

Rec. 
Type 

WHO 
Type 

1 or 0 APPR Appearance 0 Appearance O 1 3/4/5/6 

1 or 0 LIQ Liquefaction 0 Liquefaction O 1 3/4/5/6 

1 or 0 VIS Viscosity 0 Viscosity O 1 3/4/5/6 

1 or 0 AGGL AgglutinationIndex 0 Agglutination O 1 3/4/5/6 

1 or 0 AGGR AggregationIndex 0 Aggregation O 1 3/4/5/6 

1 or 0 STAND Chamber 0 Sperm Conc. Chamber Standard O 1 3/4/5/6 

Automated Test Data 

1 or 0 NLMORPH Morphology 0.0 % Normal Morphology (WHO 5th) O 1 3/4/5/6 

1 or 0 CONC TSC 0.0 Total Sperm Concentration (M/ml) O 1 3/4/5/6 

1 or 0 MSC MSC 0.0 Motile Sperm Concentration O 1 3/4/5/6 

1 or 0 MOT Motility 0.0 Total Motility (PR+NP) (%) O 1 3/4/5/6 

1 or 0 PMOT PMOT 0.0 Progressive (%) O 1 6 

1 or 0 PMOT PMOTA 0.0 Progressive Motility (PR) (%) O 1 5 

1 or 0 RPMOT PMOTA 0.0  Rapidly Progressive (%) O 1 6 

1 or 0 SPMOT PMOTB 0.0 Slowly Progressive (%) O 1 6 

1 or 0 RPMOT PMOTA 0.0  Rapid Progressive Motile Sperm (a) (%) O 1 3/4/6 

1 or 0 SPMOT PMOTB 0.0 Slow Progressive Motile Sperm (b) (%) O 1 3/4/6 

1 or 0 NPMOT Nonprog_Motility 0.0 Nonprogressive Motility (%) O 1 3/4/5/6 

1 or 0 IMMOT Immotility 0.0 Immotility (%) O 1 3/4/5/6 

1 or 0 FSC FSC 0.0 Functional Sperm Concentration  O 1 3/4/5/6 

1 or 0 PMSCA PMSC 0.0   Progressively Motile Sperm Conc (M/ml) O 1 6 

1 or 0 PMSCA PMSCA 0.0   Rapid Pr. Motile Sperm Conc. (M/ml) O 1 6 

1 or 0 PMSCB PMSCB 0.0   Slow Pr. Motile Sperm Conc. (M/ml) O 1 6 

1 or 0 PMSCA PMSCA 0.0   Progressively Motile Sperm Conc (a) (M/ml) O 1 3/4/5 

1 or 0 PMSCB PMSCB 0.0   Progressively Motile Sperm Conc (b) M/ml O 1 3/4 

1 or 0 VELOC Average_Velocity 0.0 Velocity of the Sperm (Micron/Sec) O 1 3/4/5/6 

1 or 0 ALLS All_Sperm 0.0 Sperm #  (M) O 1 3/4/5/6 

1 or 0 MOTSPE Motile_Sperm 0.0 Motile Sperm (M) O 1 3/4/5/6 

1 or 0 PMOTSPE Prog_Motile_Sperm 0.0 Prog. Motile Sperm (M) O 1 3/4/5/6 

1 or 0 FUNCSPE Functional_Sperm 0.0 Functional Sperm  (M)  O 1 3/4/5/6 

1 or 0 TMORPH Total_Morph 0.0 Morph. Normal Sperm (M) O 1 3/4/5/6 

1 or 0 SMI SMI 0.0 Sperm Motility Index O 1 3/4/5/6 

1 or 0 PH PH 0.0 PH of the semen O 1 3/4/5/6 

1 or 0 WBCCONC WBC_Concentration 0 WBC Concentration in the semen O 1 3/4/5/6 

Post-Vasectomy Automated Test Data 

1 or 0 HSMOT HS_Motile 0.0 # Motile Sperm (PV) O 1 3/4/5/6 

1 or 0 HSIMM HS_Immotile 0.0 # Immotile Sperm (PV) O 1 3/4/5/6 

1 or 0 HSTOTMOT HS_Total_Motile 0.0 # Motile Sperm/Vol M/Vol (PV) O 1 3/4/5/6 

1 or 0  HSTOTMOTIMM HS_Total_Motile_Immotile 0.0 # Total Sperm/Vol M/Vol (PV) O 1 3/4/5/6 

1 or 0 HSTOTIMM HS_Total_Immotile 0.0 # Immotile Sperm/Vol M/Vol (PV) O 1 3/4/5/6 

1 or 0 HSTOTSPE HS_Total_Sperm 0.0 # Total Sperm (PV) O 1 3/4/5/6 

Manual Test Data 

1 or 0 AGLUC a_glucos_m 0.0 a-glucosidase (mU) O 1 3/4/5/6 

1 or 0 FRUC FructSemPlas_m 0.0 Fructose (mmol/ejac.) O 1 3/4/5/6 

1 or 0 ZINC Zinc_m 0.0 Zinc (mmol/ejac.) O 1 3/4/5/6 

1 or 0 NORFOR Normal_Forms_m 0.0 Morphology % Normal Forms (%) O 1 3/4/5/6 

1 or 0 HEADDEF Head_Defects_m 0.0 Morphology Head Defects (%) O 1 3/4/5/6 

1 or 0 NEAKMID Neck_Midpiece_Defects_m 0.0 Morphology Neck/Midpiece (%) O 1 3/4/5/6 
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Transfer Flag Field Code 
Field Name in 

MES Data Base 
Format Description 

Msg 
Type 

Rec. 
Type 

WHO 
Type 

1 or 0 TAILDEF Tail_Defects_m 0.0 Morphology Tail Defects (%) O 1 3/4/5/6 

1 or 0 CYTOP Cytop_drop_m 0.0   Morphology Cytoplasmic Droplets (%) O 1 3/4/5/6 

1 or 0 PINHEAD Pinheads_m 0.0 Morphology Pinheads (%) O 1 3/4/5/6 

1 or 0 ROUNCELL Round_cells 0.0 Round cells (M/ml) O 1 3/4/5/6 

1 or 0 VIAB Vitality 0.0 Viability (%) O 1 3/4/5/6 

1 or 0 RBC RBC 0.0 Red Blood Cells (M/ml) O 1 3/4/5/6 

1 or 0 OTH Other_m 0.0   Other O 1 3/4/5/6 

Main Control Data 

AUTOMATIC SID Serial_Number String Number identifying the device P 2 3/4/5/6 

AUTOMATIC RTY Record Type 0 Record Type: 0 –Test 1 – Control P 2 3/4/5/6 

AUTOMATIC FIC Fields count 0 # Fields in 1 record transferred to LIS P 2 3/4/5/6 

Controls Data 

AUTOMATIC FIC Fields count 0 # Fields in 1 record transferred to LIS O 2 3/4/5/6 

1 or 0 CTM QC_DateTime HH:MM Time the control test was run O 2 3/4/5/6 

1 or 0 CDT QC_DateTime MM/DD/YY Date the control test was run O 2 3/4/5/6 

1 or 0 CLE Control_Level 0 

Control Level:  
1 – Level 1  
2 – level 2  
3 – Negative Control 

O 2 

3/4/5/6 

1 or 0 CTY Control_Type 0 

Control Type:  
0 - Latex-beads  
1 - Stabilized Sperm CAP  
2 - Stabilized Sperm MES 

O 2 

3/4/5/6 

1 or 0 LOT Lot String Lot Number  O 2 3/4/5/6 

1 or 0 EXD Exp_Date MM/YY Expire Date O 2 3/4/5/6 

1 or 0 TAR Target_Val 0.0 Target Value O 2 3/4/5/6 

1 or 0 RAN Target_Perc 0.0 Range +/- O 2 3/4/5/6 

1 or 0 CTS Control_TSC 0.0 Conc. Results O 2 3/4/5/6 

1 or 0 RST Over_Range 0 Range Status Empty-Normal 0-High 1- Low O 2 3/4/5/6 

1 or 0 COA Correction 0.0 Corrective Action O 2 3/4/5/6 

1 or 0 CMSC MSC 0.0 MSC O 2 3/4/5/6 
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 Appendix 2.0 – Data Flow Protocol 
 Once the system is installed, the host computer acts as a “listener” and responds to messages sent 

from the SQA-VISION computer.   The “listener” responds with an “acknowledge” to confirm whether 
the data was accepted correctly. 

 

Phase 1:  Message structure 
 Three types of messages, with unique fields, can be sent to the host computer: 

1. Facility Data [H] 

2. Patient Data [P] 

3. Test Data [O] for a specific Patient 

A message is composed of several delimited components.  Two levels of delimiter are used – vertical 

bar (|) as the primary, and caret (^) as the secondary. The primary delimiter (|) comes before the 

parameter name, and the secondary delimiter (^) comes before and after the parameter value i.e. 

|SID^123456789^  

Phase 1.1:  Protocol 1 

The message structure contains the following items: 

1. [STX] 

2. Frame number: 0-7 

3. Message type indicator: (H) for Facility Data, (P) for Patient Data, (O) for Test Data. 

4. List of fields and values, separated by primary (|) and secondary (^) delimiters. As indicated 

before, each type of message has it’s own unique fields (See Appendix 1.0 – Field list). 

5. [ETX] 

6. Check Sum number. 

7. [CR]  

8. [LF]  

ASCII Values: 
[STX] = 2, [ETX] = 3, [ACK] = 6, [LF] = 10, [CR] = 13, [NAK] = 21 

Example: [STX]2O|SN#^52^|SID^6^|FIC^1^|ATM^08:10^[ETX]8D[CRLF] 

Primary / 
Secondary 

Piece 
Description Example  

1 [STX] – marks the beginning of the message STX 

2 Frame Number 2 

3 Message type indicator  O 

4 
Parameter Name: Serial Number 

Field Code: SN#   Field value:  52 
SN#^52^ 

5 
Parameter Name: Sample Number 

Field Code: SID    Field value: 6 
SID^6^ 

6 

Parameter Name: field count -Number of 

result fields to follow 

Field Code: FIC    Field value: 1 

FIC^1^ 

7 
Parameter Name: Test Time 

Field Code: ATM   Field value: 08:10 
ATM^08:10^ 

8 [ETX] – marks the end of the fields list  ETX 

9 Check Sum Number(HEX) 8D 

10 [CR] CR 

11 [LF] LF 
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Phase 1.1.1:  Host Response 
 The host must respond with [ACK] character to confirm that the data was accepted correctly and with 

a [NAK] in cases where erroneous data is received. 

 

Phase 1.1.2:  Message Order 
 The order in which the messages are sent to the computer is as follows: 

1. First, the Facility Data [H]. 

2. Second, the Patient Data [P]. 

3. Last, the Test Data [O] relevant to the first patient and all subsequent patients in the queue 

is sent until all of the Test Data messages for all of the Patients are successfully transferred to 

the LIS.  

 

Phase 1.1.3:  Frame Number 
 For each message, the first character after the [STX] is a number between 0 and 7. This number is 

the Frame Number. The Frame Number is increased by 1 each time a message is successfully sent. 

When the Frame Number reaches the value of 7, the Frame Number will reset to 0.  

If the message has not been sent successfully (Received [NAK] from Host) it will be resent with the 

same Frame Number. As stated above (section 9.2) after five consecutive [NAK] are sent, the MES 

V-Sperm Gold Computer discards the transaction to prevent an endless loop. 

 

Phase 1.1.4:  Example 
 Below is an example of the MES V-Sperm and Host computer communication: 

MES V-Sperm Gold Computer:  
[STX]0H| MES SQA-V|FIC^2^|TFN^Keiser^|TFC^New York^[ETX]52[CR][LF] 

HOST:  
[ACK] 

MES V-Sperm Gold Computer:  

[STX]1P|PID^173^|RTY^0^|FIC^1^|PBD^07/08/78^[ETX]19[CR][LF]  

HOST:  
[ACK] 

MES V-Sperm Gold Computer: 

[STX]2O|SN#^52^|SID^6^|FIC^5^|ATM^08:07^|ADT^10/26/06^|VOL^6.0^| 

NLMORPH^^|CONC^114.8^[ETX]A1[CR][LF] 

HOST:  
[ACK] 

MES V-Sperm Gold Computer: 

[STX]3O|SN#^52^|SID^7^|FIC^5^|ATM^09:20^|ADT^10/26/06^|VOL^6.0^| 

NLMORPH^^|CONC^321.8^[ETX]40[CR][LF] 

HOST:  
[ACK] 

MES V-Sperm Gold Computer:  

[STX]4P|SID^15^|RTY^1^|FIC^0^[ETX]A6[CR][LF] 

HOST:  
[ACK] 

MES V-Sperm Gold Computer: 

[STX]5O|FIC^8^|LOT^1^|EXD^01/00^|TAR^1.0^|RAN^1.0^|CTS^5.3^|RST^1^|COA^1^| 

CMSC^^ETX33[CR][LF] 

HOST:  
[ACK] 

 
Phase 1.2:  Protocol 2 (Kaiser) 

 This specification has been updated to eliminate the initial [ENQ] / [ACK] sequence because it is not 

required. Whenever the LMS interface program is running it will be ready to receive data.  
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ASCII Values: 
[STX] = 2, [ETX] = 3, [ACK] = 6, [LF] = 10, [CR] = 13, [NAK] = 21 
 
  

Primary / 
Secondary 

Piece 

Description Example Data 

1 
Interface software version – used to verify that our software is 
written for the correct version of your interface. 

MES SQA-V 

2 
Instrument Identifier – Used to uniquely identify the instrument 
in case in the future, the interface can send data from multiple 
instruments. 

SN# 10550 

3 
Test Type 0 - Normal Test 1- Control 

Test 

3 Specimen number 123456789 

4 Number of result fields to follow 10 

5 Result Field 1 ATM^14:20^ 

5/1 Assay Code ATM 

5/2 Result Value 14:20 

5/3 Flag (for future use)  

6-nn Result Field 2 – Same as 5 VOL^1.5^ 

Phase 1.2.1:  Example 

MES V-Sperm Gold Computer: 
[STX]MES SQA V1.2|SN# 10550| 

RTY^0^|123456789|9|ATM^14:20^|VOL^1.5^|NLMORPH^25^|CONC^20.5^| 

NPMOT^14^|SPMOT^31^|RPMOT^77^|TPCOUNT^31^[ETX]96[CR][LF] 

HOST:  

[ACK] 

 

Phase 2:  Check Sum Calculation 
 Example: 

 

[STX]1O|SN#^52^|SID^3^|FIC^5^|ATM^07:41^|ADT^10/26/06^|VOL^5.0^ 

|NLMORPH^^|CONC^125.3^[ETX]96[CR][LF] 

 

A standard ASTM checksum calculation is used.  The checksum calculation for the example above is 

displayed below: 

1. Set chksum = mod(chksum,256); Extract the least significant 8 bits 

2. Set A=mod(chksum,16); Extract the least significant 4 bits 

3. Set B=int(chksum/16); Extract the most significant 4 bits 

Based on the conditions below… 

• The values of A and B are converted to HEX format  

• The numbers 0 through 9 are unchanged 

• The numbers 10 through 16 (decimal format) are converted to A through F (HEX format) 

resulting in 2 single-byte values. 

 

…the Check Sum of the ASCII values is 6038  

• The value associated with #1 (above) is 150 (the least significant 8 bits) 

• The value associated with #2 (above) is 6 (the least significant 4 bits) 

• The value associated with #3 (above) is 9 (the most significant 4 bits) 

Comments: 

1. The [STX], [CR] and [LF] values are not included in the checksum calculation 

2. The check sum calculation used the [ETX] value as 3 
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